Google maps error

Incident Report for Platform status

Resolved

This incident has been resolved.
Posted May 04, 2026 - 10:38 BST

Identified

We are aware of an issue with the mapping page. We are currently fixing it.
Posted May 04, 2026 - 08:54 BST
This incident affected: Services (Web app).